03
nov

HowTO Instalando YUM no Linux Red Hat 4 Enterprise

Pessoal!

Demorou mas vou postar um ótimo passo a passo que salvou minha vida nestes ultimos dias hehehe!
Seguinte estou rodando um Sistema de monitoramento no Linux Red Hat 4 Enterprise, com isso preciso de PHP, Pear, Mysql e Apache (HTTPD). Como no Red Hat por padrão é utilizado o PHP na versão 4 junto com Mysql 4, tive problemas para gerar gráficos pois a biblioteca “GD” não está instalada. Com a instalação do yum consegui instalar.
Com isso vejo na obrigação de compartilhar está dica com todos.
Vamos começar então.

Para os usuários que não conhecem o YUM (Yellow dog Updater Modified) , é um software que é responsavel por instalar, atualizar, remover pacotes do tipo RPM, Funciona como o Apt-Get em distribuições Debian.
O yum facilita a vida de todos porque o mesmo consegue resolver todas dependencias automanticamente ao contrário do rpm.
Obs: O yum resolve dependências sozinho se estiver configurado nos repositórios do seu Micro Computador.

Mas também podemos utilizar o comando padrão do Red Hat o Up2date. Só tem um problema este comando só faz download dos repositórios oficiais da Red Hat então como é uma distribuição paga já sabe,

Agora sim! deixa de bla, bla, bla….. siga os passos abaixo para começar a instalação do YUM.

Primeiro passo:

Temos que baixar o arquivo rpm do YUM para o Red Hat 4. Pode ser encontrado facilmente na internet, para ajudar o povo vou colar o link do site e o nome do pacote em questão.

Nome do pacote a ser baixado:
yum-2.4.2-04.el.rf RPM for noarch

Link do Site para download do pacote acima
http://fr.rpmfind.net/linux/RPM/dag/redhat/el4/x86_64/yum-2.4.2-0.4.el4.rf.noarch.html

Depois de baixado o pacote do yum faça o comando abaixo para instalar.

# rpm -hiv yum-2.4.2-0.4.el4.rf.noarch.rpm

Ao rodar o comando RPM como falei pode acontecer alguns problemas como dependências. se acontecer o problema abaixo tem solução

Error: Failed dependencies:
python-elementtree is needed by yum-2.4.2-0.4.el4.rf.noarch
python-sqlite is needed by yum-2.4.2-0.4.el4.rf.noarch
urlgrabber is needed by yum-2.4.2-0.4.el4.rf.noarch



Para ajudar mais um vez o pessoal vou postar os links para downloads dos pacotes. Se por algum motivo os mesmo tiver expirado, vão ter que procurar no google.

Pacote: python-elementtree-1.2.6-7.el4.rf.i386.rpm
wget ftp://194.199.20.114/linux/dag/redhat/el4/en/i386/dag/RPMS/python-elementtree-1.2.6-7.el4.rf.i386.rpm
# rpm -hiv python-elementtree-1.2.6-7.el4.rf.i386.rpm

Pacote: python-sqlite-1.0.1-1.2.el4.rf.i386.rpm
wget ftp://194.199.20.114/linux/dag/redhat/el4/en/i386/dag/RPMS/python-sqlite-1.0.1-1.2.el4.rf.i386.rpm
# rpm -hiv python-sqlite-1.0.1-1.2.el4.rf.i386.rpm

Pacote: python-urlgrabber-2.9.7-1.2.el4.rf.noarch.rpm
wget ftp://194.199.20.114/linux/dag/redhat/el4/en/i386/dag/RPMS/python-urlgrabber-2.9.7-1.2.el4.rf.noarch.rpm
# rpm -hiv python-urlgrabber-2.9.7-1.2.el4.rf.noarch.rpm

Na instalação dos pacotes acima só tive problema com um “pacote python-sqlite-1.0.1-1.2.el4.rf.i386.rpm”, que teve problemas com dependência.
Para resolver este problema foi simples no comando de instalação adicionei o seguinte parametro:
# rpm -hiv –nodeps python-sqlite-1.0.1-1.2.el4.rf.i386.rpm

Pronto! mas não pense que acabou agora vamos criar a lista de repositórios que o yum utiliza para fazer a busca dos pacotes.

Segundo passo:

Vamos criar as listas dos repositórios.
Primeiro crie um diretório chamado “yum.repos.d”, que deve ficar em /etc/. Neste diretório vão ficar todos arquivos de repositórios que serão criados.

#mkdir /etc/yum.repo.d

Obs: Quando finalizar a configuração e não funcionar o yum veja se o mesmo cria um diretório chamado yum.repo.d no /etc. Não sei o que acontece mas teve um Red Hat 4 que ficou assim após ter feito o procedimento. Caso acontece basta copiar todos os arquivos de repositórios para este diretório que vai resolver o problema.

Agora vamos criar o Primeiro arquivo chamado “dag.repo”, com o seguinte conteúdo:

[dag]
name = Dag
enabled = 1
baseurl = http://dag.freshrpms.net/redhat/el4/en/$basearch/dag/
http = //ftp.heanet.ie/pub/freshrpms/pub/dag/redhat/el4/en/$basearch/dag/
gpgcheck = True

Crie este arquivo com o seguinte novo “dries.repo”, Cole o conteúdo abaixo:

[dries]
name=Extra RedHat EL 4 rpms dries – $releasever – $basearch
baseurl=http://apt.sw.be/dries/redhat/el4/en/$basearch/dries/RPMS
gpgcheck=1
enabled=1
gpgkey=http://dries.ulyssis.org/ayo/RPM-GPG-KEY.dries.txt

Mais um arquivo chamado “livna”, com o seguinte conteúdo:

[livna]
name=Fedora Core 4 – i386 – livna
baseurl=http://rpm.livna.org/fedora/4/i386/RPMS.lvn
failovermethod=priority

Para finalizar “jpackage.repo”, cole as seguintes informações:

[jpackage-generic]
name=JPackage (free), generic
mirrorlist=http://www.jpackage.org/jpackage_generic.txt
failovermethod=priority
gpgcheck=1
gpgkey=http://www.jpackage.org/jpackage.asc
enabled=1

Também pode criar um arquivo com os repositórios de pacotes liberados pela Red Hat em parceria com a CentOS.

Para isto basta criar o arquivo “centos.repo”, colar as informações abaixo:

[base]
name=CentOS-$releasever – Base
baseurl=http://mirror.centos.org/centos/4/os/i386/
gpgcheck=1
[updates]
name=Red Hat Linux $releasever – Updates
baseurl=http://mirror.centos.org/centos/4/os/i386/
gpgcheck=1

Obs: Todos arquivos criados , devem ficar em /etc/yum.repos.d/.

Finalmente acabou…. Agora vem o mais importante o teste! xD

Para fazer os devidos testes faça os comandos abaixo:

#yum cleanall

# yum check-update

Vai perceber que depois de um tempo vai carregar a lista dos repositórios do banco de dados, com os arquivos disponíveis. Os arquivos carregados não pagos então podem ser baixados.

Pessoal como disse no começo deste post, este procedimento foi feito para resolver um problema com o pacote php-gd. Então abaixo vai uma dica para quem estiver procurando uma solução para este problema.

Já com o yum instalado podemos fazer o comando abaixo para instalar a biblioteca do php-gd faça:

#yum -y install php-gd

Obs: Depois de fazer o comando acima, se seu Linux não foi atualizado atualmente então vai ter como dependência alguns pacotes como php.4.3, mysql-server, mysql-devel, php.4, php4-pear entre outros. Fica a sua preferencia a substituição do php e mysql atual por atualizados.

No meu caso como não conheço a fundo o Sistema nem os scripts de Mysql decidi instalar o php-gd de outra forma.

Baixei o arquivo .rpm e instalei pelo RPM mesmo.

Nome do arquivo:
php-gd-4.3.9-3.i386.rpm

Link para o site:

http://rpmfind.net/linux/RPM/fedora/3/i386/php-gd-4.3.9-3.i386.html

Pronto feito isso agora é só fazer o comando abaixo para instalar.

#rpm -ivh php-gd-4.3.9-3.i386.rpm

Caso tenha alguma dependência, não vai ser preciso procurar por pacotes para resolver faça o comando abaixo que funciona:

# rpm -ivh –replacefiles –nodeps php-gd-4.3.9-3.i386.rpm.

Pronto pessoal agora está funcionando.
Para testar faça o seguinte:

Reinicie o Apache:

#service httpd restart.

Agora vc pode criar um arquivo do php.info que deve ser salvo em /var/www/html/

Veja Exemplo:

[root@diogoheavymetal ~]# cat /var/www/html/info.php

< ?php
phpinfo();
?>

Pronto veja que a biblioteca GD aparece logo abaixo de FTP….. Só alegria se tiver está informação aparecendo no Info.php. xD

Pessoal espero ter ajudado e vou continuar buscando por artigos e novidades no mundo da tecnologia e resolução de problemas que pode ser encontrado e vivido no dia-a-dia de trabalho……

Seja livre use LINUX…… Windows as tela VISTA….xD

Diogo P Freitas.

2 Responses to “HowTO Instalando YUM no Linux Red Hat 4 Enterprise”

  1. 1
    fernando Says:

    Tive problemas com os mirrors.

    Error: Cannot find baseurl or name for server ‘rsync’. Skipping
    Error: Cannot find baseurl or name for server ‘jpackage-generic’. Skipping
    Gathering header information file(s) from server(s)
    Server: CentOS-9 . Base
    Server: Dag
    Server: Extra RedHat EL 4 rpms dries . 9 . i386
    retrygrab() failed for:
    http://apt.sw.be/dries/redhat/el4/en/i386/dries/RPMS/headers/header.info
    Executing failover method
    failover: out of servers to try
    Error getting file http://apt.sw.be/dries/redhat/el4/en/i386/dries/RPMS/headers/header.info
    [Errno 4] IOError: HTTP Error 404: Not Found

© 2017 Cafe TI – pra perder o sono. | [RSS] Artigos and [RSS] Comentários

Design by Web4 Sudoku - Powered By Wordpress